Yönetici Panelinden Yükseltme
Güvenlik güncellemeleri ve diğer ufak güncellemer yönetici panelin'in Paketler bölümünden otomatik olarak indirilip kurulabilmektedirler. Bu tür güncellemeleri bu şekilde yapmanız tavsiye edilir (mesela 1.1.3'ten 1.1.4'e).

Notlar:
[list][li]Yönetici panelinden upgrade işlemi [u]genelde modifikasyon ve diğer değişikliklere zarar vermez.[/li][/list]


[size=13pt]Upgrade Paketi ile Yükseltme
1) [url=http://www.simplemachines.org/download.php]Downloads[/url] bölümünden yükseltme yapmak istediğiniz sürüme ait upgrade paketini indirin. Dikkat edin, update değil, upgrade. Mesela forum sürümünü 1.0.5'ten 1.1 RC1'e güncellemek istiyorsunuz. Örnek dosya adımız budur: smf_1-1-rc1_upgrade.zip
2) Daha sonra [url=http://www.simplemachines.org/download/?languages]dil dosyaları[/url] bölümünden güncelleme yapmak istediğiniz sürüme ait Türkçe dil dosyalarını indirin. (Forumu Türkçe kullanıyorsanız tabi) Örneğimizdeki dosya adı: smf_1-1-rc1_turkish.zip
Şimdi elimizde iki adet paket var. Bunları dilersek bilgisayarımızda paketten çıkarabilir, dilersek de (cPanel'i olanlar için) sitemize yükleyip doğrudan sunucu üzerinde paketten çıkarabiliriz.
Şimdi en basiti olan birinicisini yapalım. Bu iki paketin içindekileri Winzip veya benzeri yardımıyla bilgisayarımıza çıkartıyoruz. Sonra aynen olduğu gibi sitemize yüklüyoruz. (FTP veya benzeri ile)
Eski dosyaların üzerine yazıyoruz.
3) Son olarak upgrade.php isimli dosyayı çalıştırıyoruz. Ör: [code]http://www.site.com/forum/upgrade.php[/code]Bunu açınca bir tane düğme çıkacak. Ona basın yeter :)
Yeni sürümünüz hayırlı olsun. upgrade.php dosyasını silmeyi unutmayın.

Notlar:
[list]
[li]Güncelleme işlemi ileriye doğru olur. 1.1.x sürümlerinden 1.0.x sürümünlerine geri dönemezsiniz![/li]
[li]Bu işlemle kessinlikle forumununzdaki mesajlar, konular, bölümler, vs. silinmez, kaybolmaz.[/li]
[li]Kurulu modifikasyonlar çalışmaz, modifikasyonların konularını okumanız ve güncelleme işlemi öncesinde bütün modifikasyonlarınızı kaldırmanız tavsiye edilir. Upgrade işleminden sonra tekrar kurabilirsiniz.[/li]
[li]Kurulu temalar için de aynı şey geçerlidir.[/li]
[li]Önemli güvenlik güncellemeleri (mesela 1.1'den 1.1.1'e veya 1.1.1'den 1.1.2'ye) modifikasyon paketi olarak da yüklenebilir. Paketler sayfasındaki uyarıyı izleyin.[/li]
[/list]

Önemli: SMF 1.1 RC3 sürümünde eklenen UTF-8 çevirimi işlemini uygularken dikkatli olun, veri kaybına yol açabilirsiniz! Mutlaka birden fazla veritabanı yedeği alın

Alıntıdır

Beğeniler: 0
Favoriler: 0
İzlenmeler: 4475
favori
like
share
Agura Tarih: 31.07.2009 01:22
bu upgrade_1-1 ile upgrade_1-0 mysqldan insert yapmamız gereklimi? yoksa direk hostamı atıyoruz ? forumun oldugu yere daha önce hiç yapmadım?
MAVi Tarih: 11.07.2009 02:32
tşk..
h3llguard Tarih: 25.05.2009 16:37
emeğine sağlık
FreddyKrueger Tarih: 09.02.2009 16:18
[COLOR="#c0ccf4"][QUOTE=ihtiyar1971;3241906]güncellme yaparken

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'LENGTH(code) DESC' at line 2
hatası alıyorum napmam gerekir.

Upqrade EdeCeqiniz Paketteki .sql DoSyaSını Açın ve Bunu BuLun,

ORDER BY LENGTH(code) DESC;

BununLa Deqi$tirin,

ORDER BY code DESC;

Daha Sonra Tekrar Deneyin...
ihtiyar1971 Tarih: 09.02.2009 10:54
güncellme yaparken

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'LENGTH(code) DESC' at line 2
hatası alıyorum napmam gerekir.
Jawish Tarih: 05.02.2009 07:08
dfsdsfsfdsfdsf
sibit Tarih: 11.12.2008 20:47
tesskurler
alacatili Tarih: 07.12.2008 19:22
teşekkürler dostum
zeki36 Tarih: 23.11.2008 09:36
sağolun bakıyorum